Features in 1.35.*

Forum for questions and support relating to 1.35.x development only.
pdt5774
Posts: 3
Joined: Tue Feb 04, 2020 10:45 pm

Re: Features in 1.35.*

Post by pdt5774 » Tue Feb 09, 2021 8:15 pm

Kudos on the quick attention of typing errors. Yet you provided no specifics as to the way to remove "bleeding edge" Zonerminder updates from general Ubuntu updates. A quick edit of Ubuntu /etc/apt/sources.list.d might have been more valuable information to others. However, you received the warm fuzzy from your reply, that's great! ( chuckling )

No, I was NOT aware recent installs of Zoneminder included "bleeding edge" updates with the addition of "iconnor-ubuntu-zoneminder-master-focal.list" in /etc/apt/sources.list.d file pulled along with general Ubuntu updates. I seen NO reference to this fact in recent install instructions of Zoneminder. Had instructions provided a Note: suggesting a choice of "general" Zoneminder updates and "bleeding edge" updates, I would have certainly NOT set the new user's system up using bleeding edge updates option. I can repair his system easily and explain what happened. The breakage just came at a very vulnerable time in his learning curve. Mine as well.

I've been a steady user & supporter (including financial) of Zoneminder since before 2009 and I intend on continuing using and supporting in the future. This is the one and only posting I've made on the forums. I'm an avid "read the docs" reader. I was simply blind-sided by this recent event.

A great many thanks fellas for your time and efforts of keeping Zoneminder the best software on the planet!!

gbruneau
Posts: 15
Joined: Fri Jun 07, 2019 8:27 pm

Re: Features in 1.35.*

Post by gbruneau » Fri Feb 12, 2021 10:15 pm

Hey Isaac,

Small typo in the bootstrap version you mentioned. ZM 1.35 is currently using Bootstrap 4.5, not bootstrap 3.

User avatar
The Eye
Posts: 9
Joined: Thu Feb 18, 2021 7:50 pm

Re: Features in 1.35.*

Post by The Eye » Fri Feb 19, 2021 7:41 pm

I start feeling the urge to clean up some Perl mess.

What is the minimum required Perl version for ZoneMinder 1.35.* ?

Debian Jessie has 5.20 - released 2014 (see https://en.wikipedia.org/wiki/Perl_5_version_history)
Surely one could consider that a minimum requirement? Yes?
testing ZM v1.34.23 - a Turnkey Linux appliance VM running on Proxmox
VM has currently 8 Denverton Cores, 4GB RAM of which are 2.5GB shared memory, 1TB disk space
2 x Reolink RLC-410 5MP

kdmiller45
Posts: 3
Joined: Sat Mar 27, 2021 5:08 pm

Re: Features in 1.35.*

Post by kdmiller45 » Sat Mar 27, 2021 6:15 pm

where is the link to 1.35, I will try and upgrade

Keith

User avatar
iconnor
Posts: 1530
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Features in 1.35.*

Post by iconnor » Sat Mar 27, 2021 9:53 pm

Minimum perl is 5.006.

gerdesj
Posts: 18
Joined: Wed Jan 14, 2015 4:00 pm

Re: Features in 1.35.*

Post by gerdesj » Sun Apr 04, 2021 9:25 pm

If you have VNC as a source then perhaps consider RDP via xfreerdp. I can envision all sorts of fun and games with that functionality available and no need for additional stuff on the sources.

alabamatoy
Posts: 263
Joined: Sun Jun 05, 2016 2:53 pm

Re: Features in 1.35.*

Post by alabamatoy » Mon Apr 19, 2021 1:42 pm

iconnor wrote:
Fri Oct 02, 2020 8:18 pm
- Clicking on username in header will now list other logged in users if you have SystemView ppermission.
Very nice addition. Shows past logins, but apparently does not include logins via API. I used ZMNinja and it doesnt get included in the list. The display of the light lines is almost invisible on my display, needs to use black text.

User avatar
iconnor
Posts: 1530
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Features in 1.35.*

Post by iconnor » Wed May 05, 2021 7:48 pm

added hwacell for vaapi and nvenc for encoding.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests