Can't run on docker

Support for the docker image maintained by dlandon
Post Reply
bethesda-arx
Posts: 4
Joined: Fri Dec 04, 2020 8:37 pm

Can't run on docker

Post by bethesda-arx » Fri Dec 04, 2020 8:42 pm

running latest Mac OS, and latest Docker. Followed instructions here: https://github.com/dlandon/zoneminder

Got this when looking at docker logs.

Thanks

Code: Select all

...
...
Setting up libsystemd0:amd64 (237-3ubuntu10.43) ...
(Reading database ... 39297 files and directories currently installed.)
Preparing to unpack .../libudev1_237-3ubuntu10.43_amd64.deb ...
Unpacking libudev1:amd64 (237-3ubuntu10.43) over (237-3ubuntu10.42) ...
Setting up libudev1:amd64 (237-3ubuntu10.43) ...
(Reading database ... 39297 files and directories currently installed.)
Preparing to unpack .../00-php7.4-json_7.4.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.4-json (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) over (7.4.12-3+ubuntu18.04.1+deb.sury.org+1) ...
Preparing to unpack .../01-php7.4-readline_7.4.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.4-readline (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) over (7.4.12-3+ubuntu18.04.1+deb.sury.org+1) ...
Preparing to unpack .../02-php7.4-opcache_7.4.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.4-opcache (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) over (7.4.12-3+ubuntu18.04.1+deb.sury.org+1) ...
Preparing to unpack .../03-php7.4-fpm_7.4.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.4-fpm (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) over (7.4.12-3+ubuntu18.04.1+deb.sury.org+1) ...
Preparing to unpack .../04-php7.4-mysql_7.4.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.4-mysql (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) over (7.4.12-3+ubuntu18.04.1+deb.sury.org+1) ...
Preparing to unpack .../05-php7.4-gd_7.4.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.4-gd (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) over (7.4.12-3+ubuntu18.04.1+deb.sury.org+1) ...
Preparing to unpack .../06-libapache2-mod-php7.4_7.4.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking libapache2-mod-php7.4 (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) over (7.4.12-3+ubuntu18.04.1+deb.sury.org+1) ...
Preparing to unpack .../07-php7.4-cli_7.4.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.4-cli (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) over (7.4.12-3+ubuntu18.04.1+deb.sury.org+1) ...
Preparing to unpack .../08-php7.4-common_7.4.13-1+ubuntu18.04.1+deb.sury.org+1_amd64.deb ...
Unpacking php7.4-common (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) over (7.4.12-3+ubuntu18.04.1+deb.sury.org+1) ...
Preparing to unpack .../09-libpulse0_1%3a11.1-1ubuntu7.11_amd64.deb ...
Unpacking libpulse0:amd64 (1:11.1-1ubuntu7.11) over (1:11.1-1ubuntu7.10) ...
Preparing to unpack .../10-php7.4_7.4.13-1+ubuntu18.04.1+deb.sury.org+1_all.deb ...
Unpacking php7.4 (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) over (7.4.12-3+ubuntu18.04.1+deb.sury.org+1) ...
Setting up php7.4-common (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Setting up php7.4-opcache (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Setting up php7.4-gd (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Setting up php7.4-mysql (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Setting up libpulse0:amd64 (1:11.1-1ubuntu7.11) ...
Setting up systemd (237-3ubuntu10.43) ...
Setting up php7.4-readline (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Setting up php7.4-json (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Setting up libnss-systemd:amd64 (237-3ubuntu10.43) ...
Setting up systemd-sysv (237-3ubuntu10.43) ...
Setting up php7.4-cli (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Setting up php7.4-fpm (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) ...
NOTICE: Not enabling PHP 7.4 FPM by default.
Dec  4 15:36:24 7576d22e4db7 php7.4-fpm: NOTICE: Not enabling PHP 7.4 FPM by default.
NOTICE: To enable PHP 7.4 FPM in Apache2 do:
Dec  4 15:36:24 7576d22e4db7 php7.4-fpm: NOTICE: To enable PHP 7.4 FPM in Apache2 do:
NOTICE: a2enmod proxy_fcgi setenvif
Dec  4 15:36:24 7576d22e4db7 php7.4-fpm: NOTICE: a2enmod proxy_fcgi setenvif
NOTICE: a2enconf php7.4-fpm
Dec  4 15:36:24 7576d22e4db7 php7.4-fpm: NOTICE: a2enconf php7.4-fpm
NOTICE: You are seeing this message because you have apache2 package installed.
Dec  4 15:36:24 7576d22e4db7 php7.4-fpm: NOTICE: You are seeing this message because you have apache2 package installed.
invoke-rc.d: could not determine current runlevel
invoke-rc.d: policy-rc.d denied execution of restart.
Setting up libapache2-mod-php7.4 (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) ...
libapache2-mod-php7.4: not switching MPM - already enabled
Dec  4 15:36:26 7576d22e4db7 libapache2-mod-php7.4: libapache2-mod-php7.4: not switching MPM - already enabled
Setting up libpam-systemd:amd64 (237-3ubuntu10.43) ...
Setting up php7.4 (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Processing triggers for dbus (1.12.2-1ubuntu1.2) ...
Processing triggers for libc-bin (2.27-3ubuntu1.3) ...
Processing triggers for php7.4-cli (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Processing triggers for php7.4-fpm (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) ...
invoke-rc.d: could not determine current runlevel
invoke-rc.d: policy-rc.d denied execution of restart.
NOTICE: Not enabling PHP 7.4 FPM by default.
Dec  4 15:36:26 7576d22e4db7 php7.4-fpm: NOTICE: Not enabling PHP 7.4 FPM by default.
NOTICE: To enable PHP 7.4 FPM in Apache2 do:
Dec  4 15:36:26 7576d22e4db7 php7.4-fpm: NOTICE: To enable PHP 7.4 FPM in Apache2 do:
NOTICE: a2enmod proxy_fcgi setenvif
Dec  4 15:36:26 7576d22e4db7 php7.4-fpm: NOTICE: a2enmod proxy_fcgi setenvif
NOTICE: a2enconf php7.4-fpm
Dec  4 15:36:26 7576d22e4db7 php7.4-fpm: NOTICE: a2enconf php7.4-fpm
NOTICE: You are seeing this message because you have apache2 package installed.
Dec  4 15:36:26 7576d22e4db7 php7.4-fpm: NOTICE: You are seeing this message because you have apache2 package installed.
Processing triggers for libapache2-mod-php7.4 (7.4.13-1+ubuntu18.04.1+deb.sury.org+1) ...
Reading package lists...
Building dependency tree...
Reading state information...
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
*** Running /etc/my_init.d/30_gen_ssl_keys.sh...
using existing keys in "/config/keys"
*** Running /etc/my_init.d/40_firstrun.sh...
Using existing conf folder
Moving zm.conf to config folder
Moving zmeventnotification.ini
Moving secrets.ini
Moving opencv.sh
Moving debug_opencv.sh
Moving the event notification server
Moving the pushover api
Using existing ssmtp folder
Using existing mysql database folder
Copy /config/control/ scripts to /usr/share/perl5/ZoneMinder/Control/
Copy /config/conf/ scripts to /etc/zm/conf.d/
Creating symbolink links
Using existing data directory for events
Using existing data directory for images
Using existing data directory for temp
Using existing data directory for cache
Correcting /var/cache/zoneminder/cache permissions...
no crontab for root
Setting shared memory to : 50% of 4540940 bytes
Starting services...
 * Starting Apache httpd web server apache2
 *
 * Starting MariaDB database server mysqld
   ...done.
Dec  4 15:36:32 7576d22e4db7 /etc/mysql/debian-start[11983]: Upgrading MySQL tables if necessary.
Dec  4 15:36:32 7576d22e4db7 /etc/mysql/debian-start[11987]: /usr/bin/mysql_upgrade: the '--basedir' option is always ignored
Dec  4 15:36:32 7576d22e4db7 /etc/mysql/debian-start[11987]: Looking for 'mysql' as: /usr/bin/mysql
Dec  4 15:36:32 7576d22e4db7 /etc/mysql/debian-start[11987]: Looking for 'mysqlcheck' as: /usr/bin/mysqlcheck
Dec  4 15:36:32 7576d22e4db7 /etc/mysql/debian-start[11987]: This installation of MySQL is already upgraded to 10.1.47-MariaDB, use --force if you still need to run mysql_upgrade
Dec  4 15:36:32 7576d22e4db7 /etc/mysql/debian-start[11994]: Checking for insecure root accounts.
Dec  4 15:36:32 7576d22e4db7 /etc/mysql/debian-start[11998]: Triggering myisam-recover for all MyISAM tables and aria-recover for all Aria tables
DBD::mysql::st execute failed: Table 'zm.config' doesn't exist in engine at /usr/share/perl5/ZoneMinder/Config.pm line 97.
Can't execute: Table 'zm.config' doesn't exist in engine at /usr/share/perl5/ZoneMinder/Config.pm line 147.
BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder/Config.pm line 147.
Compilation failed in require at /usr/bin/zmupdate.pl line 73.
BEGIN failed--compilation aborted at /usr/bin/zmupdate.pl line 73.
DBD::mysql::st execute failed: Table 'zm.config' doesn't exist in engine at /usr/share/perl5/ZoneMinder/Config.pm line 97.
Can't execute: Table 'zm.config' doesn't exist in engine at /usr/share/perl5/ZoneMinder/Config.pm line 147.
BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder/Config.pm line 147.
Compilation failed in require at /usr/bin/zmupdate.pl line 73.
BEGIN failed--compilation aborted at /usr/bin/zmupdate.pl line 73.
Starting ZoneMinder:
DBD::mysql::st execute failed: Table 'zm.config' doesn't exist in engine at /usr/share/perl5/ZoneMinder/Config.pm line 97.
Can't execute: Table 'zm.config' doesn't exist in engine at /usr/share/perl5/ZoneMinder/Config.pm line 147.
BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder/Config.pm line 147.
Compilation failed in require at /usr/share/perl5/ZoneMinder.pm line 33.
BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder.pm line 33.
Compilation failed in require at /usr/bin/zmpkg.pl line 34.
BEGIN failed--compilation aborted at /usr/bin/zmpkg.pl line 34.
ZoneMinder failed to start

*** /etc/my_init.d/40_firstrun.sh failed with status 255

*** Killing all processes...
Dec  4 15:36:32 7576d22e4db7 syslog-ng[35]: syslog-ng shutting down; version='3.13.2'

Magic919
Posts: 493
Joined: Wed Sep 18, 2013 6:56 am

Re: Can't run on docker

Post by Magic919 » Sat Dec 05, 2020 7:17 am

Do it with the don’t start ZM option. It’s complaining about a missing DB table. Check if it has a DB. It’s either missing or lacks a table.

bethesda-arx
Posts: 4
Joined: Fri Dec 04, 2020 8:37 pm

Re: Can't run on docker

Post by bethesda-arx » Sat Dec 05, 2020 2:18 pm

Thanks. I understand Docker pretty well, so I don't get why my run experience would be any different than anyone else's to the extent that I have configured everything correctly.

I have altered my startup script but the outcome is the same.

-e NO_START_VM="1"

Magic919
Posts: 493
Joined: Wed Sep 18, 2013 6:56 am

Re: Can't run on docker

Post by Magic919 » Sat Dec 05, 2020 2:28 pm

I agree, it ought to just work for you. I don't run this as a container, so I can't compare.

Hopefully you meant NO_START_ZM="1", rather than VM.

bethesda-arx
Posts: 4
Joined: Fri Dec 04, 2020 8:37 pm

Re: Can't run on docker

Post by bethesda-arx » Sat Dec 05, 2020 2:44 pm

Thanks for seeing my typo.

I'm throwing in the towel, this is ridiculous.

Magic919
Posts: 493
Joined: Wed Sep 18, 2013 6:56 am

Re: Can't run on docker

Post by Magic919 » Sat Dec 05, 2020 6:34 pm

I have no idea of the cause, but I think this is specific to OSX. I know that’s no help to you, but that’s the impression I get when I Google the error message. I’d have thought the Docker route would avoid such things, but clearly not.

bethesda-arx
Posts: 4
Joined: Fri Dec 04, 2020 8:37 pm

Re: Can't run on docker

Post by bethesda-arx » Sat Dec 05, 2020 6:47 pm

Yeah thanks again for your help, so much for Docker abstracting away the underlying OS.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests