ZM @ RPi 2 doesn't work

Forum for questions and support relating to the 1.25.x releases only.
Post Reply
_peterlast
Posts: 14
Joined: Tue Apr 14, 2015 6:01 pm

ZM @ RPi 2 doesn't work

Post by _peterlast » Thu Jul 09, 2015 8:03 pm

I can't get 1.25 from the raspbian repo to work :( It doesn't show any image. I get some errors. Can anyone help me?

Apache2 error.log:

Code: Select all

[Wed Jul 08 19:11:11 2015] [error] [client 192.168.0.23] ERR [socket_sendto( /tmp/zm/zms-966606s.sock ) failed: No such file or directory], referer: http://192.168.0.215/zoneminder/index.php?view=watch&mid=1
Access logs has several of these entries:

Code: Select all

192.168.0.23 - - [08/Jul/2015:19:59:28 +0200] "GET /zoneminder/index.php HTTP/1.1" 200 2393 "http://192.168.0.215/zoneminder/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0"

192.168.0.23 - - [08/Jul/2015:20:01:50 +0200] "POST /zoneminder/index.php HTTP/1.1" 200 530 "http://192.168.0.215/zoneminder/index.php?view=watch&mid=1" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0"
Zoneminder log is full of:

Code: Select all

2015-07-08 20:08:52.413720	web_php	3196	ERR	socket_sendto( /tmp/zm/zms-966606s.sock ) failed: No such file or directory	/usr/share/zoneminder/includes/functions.php
Also has a few other errors but the above fills 80% of the error log entries.

I have searched for quite some time and could only find that I might need to add cgi-bin variables to Apache2. So I created zoneminder.conf in conf.d with contents:

Code: Select all

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/

   <Directory>
      AllowOverride None
      Options +ExecCGI +SymLinksIfOwnerMatch
      Order allow,deny
      Allow from all
   </Directory>
/usr/lib/cgi-bin/ contains:
nph-zms zms

apache2.conf contains nothing with the string "zms" or "cgi".

willemb
Posts: 6
Joined: Fri May 01, 2015 6:05 pm

Re: ZM @ RPi 2 doesn't work

Post by willemb » Mon Jul 13, 2015 5:44 am

Here's what I've discovered so far. If I start with a fresh install of raspbian and then do ....
sudo apt-get update
sudo apt-get install apache2
sudo apt-get install zoneminder

edit /etc/mysql/my.cnf file and put a # in from of bind

sudo nano /usr/share/perl5/ZoneMinder/Memory.pm
do this ....
# line 130 - Change from:
our $arch = int(3.2*length(~0));
# To:
our $arch = 32;

then do ...
SymLink Apache file to conf.d:
sudo ln -s /etc/zm/apache.conf /etc/apache2/conf.d/zoneminder.conf

then ...

# Install Cambozola Java Plugin
mkdir ~/tmp && cd ~/tmp
wget http://www.andywilcock.com/code/cambozo ... est.tar.gz
tar xvf cambozola-latest.tar.gz
sudo cp ./cambozola-*/dist/cambozola.jar /usr/share/zoneminder
cd ~ && rm -rf ~/tmp


I then restart zoneminder service and then apache service and I get no log errors. Its all green.

My problem arises as soon as I try and record to an external hard drive setup in fstab. Then I get the dreaded socket errors. Its driving me crazy. The worst part is I had this working a couple of weeks ago to an external hard drive with no log errors but I can't remember what I did then.

willemb
Posts: 6
Joined: Fri May 01, 2015 6:05 pm

Re: ZM @ RPi 2 doesn't work

Post by willemb » Mon Jul 13, 2015 7:01 am

Well the socket errors stopped. I went into option,,,logging and turned on debug. I left that on for a while. I then went into /tmp/zm and did a rm -r zm_debug* thinking I had already turned off debug. I then realized more debug logs were popping up so I stopped zoneminder. went back into logging, turned off debug and started zoneminder again. And now its working without any socket errors.

All other aspects are working well from what I can tell.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests