zm create video out poor quality

Forum for questions and support relating to the 1.25.x releases only.
Post Reply
e_defranco
Posts: 6
Joined: Sun Jun 10, 2012 3:16 pm

zm create video out poor quality

Post by e_defranco » Sun Jun 10, 2012 3:30 pm

Hi to all.

I have just started to working with zm and have some problems.

The first one (other I have just resolved myself :) ) is that the video that zm create after an alarm is very poor quality.

The image recorded are very good but when i chose "create video" (I am not sure that on english version this is exact translation ... on italian version the option are: "genera video" ) the video generated (i test avi mpg mpeg) is very very bad ...

I suspect that the problem is some parameter passed to ffmpeg but I have no more info about how to debug this.

Can any one help me ?

Thank in advance,

Emilio

PacoLM
Posts: 971
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: zm create video out poor quality

Post by PacoLM » Mon Jun 11, 2012 6:55 am

Try with these settings in the Options::Images::FFMPEG_OUTPUT_OPTIONS -r 25 -sameq -qscale 5

Hope it helps

PacoLM

After more than 15 years, no longer using ZM as surveillance system.
Now in the dark side, using a commercial system...

e_defranco
Posts: 6
Joined: Sun Jun 10, 2012 3:16 pm

Re: zm create video out poor quality

Post by e_defranco » Mon Jun 11, 2012 5:26 pm

first of all, I am very gratefull you for your reply.

Yes, after I applied what you have suggested me, the quality of the video generated is improved, but is still lower than that of the images.

I have check value for qscale from 1 to 25 without apreciable variation ... I read ffmpeg man but I understood little ...

From ffmpeg man:

-qscale q
Use fixed video quantizer scale (VBR).
-sameq
Use same quantizer as source (implies VBR).

The output video have same square pixel that in the single images are not !!

I'm doing something wrong?

Are available some documentation about zm that explain not zm installing but zm configuration and how it works (what and where are the scripts that it use etc) ?

Emilio

PacoLM
Posts: 971
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: zm create video out poor quality

Post by PacoLM » Mon Jun 11, 2012 8:24 pm

Which values do you have in these settings (Options::Images)?

JPEG_FILE_QUALITY
JPEG_ALARM_FILE_QUALITY
JPEG_STREAM_QUALITY

Try to set them to 100, post results!

PacoLM

After more than 15 years, no longer using ZM as surveillance system.
Now in the dark side, using a commercial system...

e_defranco
Posts: 6
Joined: Sun Jun 10, 2012 3:16 pm

Re: zm create video out poor quality

Post by e_defranco » Tue Jun 12, 2012 9:16 am

The value in the field was:

JPEG_FILE_QUALITY 70
JPEG_ALARM_FILE_QUALITY 0
JPEG_STREAM_QUALITY 70

Now I have set all to 100.

The quality is no changed ... is no very bad as after that I applied your first suggestion about ffmpeg output parameters, but is lower refered to the quality of the video reproduced when you click on event number and open the event window.

This video is realy perfect, when you select create video, the video created have more noise introduced (I think) from the compression.

I don't know if this can be linked to the problem or not, but I get video input from H264 camera (grandstream 3615w, connected to the network no by wifi but with cable).

Another strange thing is that when I have create the monitor for the camera and have setted correctly the path of the source, in zm console the source column is empty ... and now, for edit the monitor option i need select it in right of zm console page and click on the edit button ....

For other cameras, I see in source column the ip of the camera and can click on it to open the edit window ...

Emilio

SURVEILLANCE
Posts: 3
Joined: Sun Jul 29, 2012 7:34 am

Re: zm create video out poor quality

Post by SURVEILLANCE » Sat Sep 01, 2012 4:59 pm

6 IP CAM EyeSight in H.264 in esecuzione su Ubuntu 12.04 e Zoneminder 1.25
Funziona tutto perfettamente ma non riesco a generare alcun video, ottendo
Extracting video failled.
Saluti.

6 IP CAM eyesight in H.264 running on Ubuntu 12.04 and 01.25 Zoneminder
Everything works perfectly but I can not generate any video, ottendo
Extracting video failled.
Greetings.
:| :|

e_defranco
Posts: 6
Joined: Sun Jun 10, 2012 3:16 pm

Re: zm create video out poor quality

Post by e_defranco » Sun Sep 02, 2012 10:19 am

Hi, your problem is more different of mine, I suggest you to open a specific post.

But, only for my info, what is the fps that you have with your cameras in h264? I have two cameras: one is the grandstream that i have mentioned in the post and the other is a allnet 2272. With the firs one i can reach 10 -15 fps but with the allnet the max fps with h264 is about 3 -4 fps.

And what is your pc load with 6 cameras ? With my test equipment that I have now (AMD Athlon x64 dual core with 3Ghz of clock) with 2 cameras I reach about a load of 2 that is good but I have no idea about what will can be the load with more cameras ... and i planing to put in service about 6 cameras ...

About your problem: but you seen the single photos before you try to make the video ? Maybe you have some permission problem on the directory ...

Emilio

compumatter
Posts: 2
Joined: Fri Dec 05, 2014 2:37 am

Re: zm create video out poor quality

Post by compumatter » Fri Dec 25, 2020 5:37 am

The biggest single difference I found was increasing the bitrate in the camera's hardware area and not in Zoneminder. Night and day from the default 1500 bitrate to say 6000. Everything changes.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests